cancelar
Mostrando los resultados de 
Buscar en lugar de 
Quiere decir: 

Problema 'explicit FTP over TLS' con router 4G

Responder
ashaw
Nuevo

Problema 'explicit FTP over TLS' con router 4G

Hola,

Hace poco cambié de un Livebox ADSL a un router 4G (la fibra no me llega y el ADSL se termina pronto). La velocidad de la nueva conexión es buena, much mejor que ADSL. PERO, ahora, cuando necesito subir archivos a las páginas web de mi negocio con Filezilla con encriptación 'explicit FTP over TLS' (lo que pide mi hosting), se tarda muuucho en establecer la conexión para subir los archivos (no la conexión initial al servidor). Al final después de unos intentos fallidos se conecta y se suben los archivos, pero lo que antes me tardaba unos segundos ahora tarda más que un minuto cada vez que quiero subir un archivo (ver abajo). ¿Algún remedio?

 

Status:      Connecting to 82.XXX.XX.XX:21...

Error:        Connection timed out after 20 seconds of inactivity

Error:        Could not connect to server

Status:      Disconnected from server

Status:      Delaying connection for 5 seconds due to previously failed connection attempt...

Status:      Connecting to 82.XXX.XX.XX:21...

Error:        Connection timed out after 20 seconds of inactivity

Error:        Could not connect to server

Status:      Disconnected from server

Status:      Delaying connection for 5 seconds due to previously failed connection attempt...

Status:      Connecting to 82.XXX.XX.XX:21...

Status:      Connection established, waiting for welcome message...

Status:      Initializing TLS...

Status:      Verifying certificate...

Status:      TLS connection established.

 

Gracias de antemano

 

un saludo

 

 

Fer_Orange
Moderator

Hola @ashaw:

 

Bienvenido/a a la Comunidad Orange.

 

¿Tienes opción de hacer una prueba a través de la conexión de tu línea móvil para ver si te ocurre lo mismo?


Si tu duda ha sido resuelta, ayuda al resto de usuarios marcándola como solución
 
 
Si lees un comentario que te ha sido útil, ayuda a mejorar la comunidad dándole un "gracias"
 


ashaw
Nuevo

Hola,

Gracias por tu mensaje. Sí, lo he probado y pasa exactamente lo mismo (que tiene su lógica siendo también 4G de Orange). O sea, no es problema de la router 4G.

 

un saludo

 

Status:      Connecting to 82.XXX.XX.XX:21...

Status:      Connection established, waiting for welcome message...

Error:        Connection timed out after 20 seconds of inactivity

Error:        Could not connect to server

Status:      Disconnected from server

Status:      Delaying connection for 5 seconds due to previously failed connection attempt...

Status:      Connecting to 82.XXX.XX.XX:21...

Status:      Connection established, waiting for welcome message...

Error:        Connection timed out after 20 seconds of inactivity

Error:        Could not connect to server

Status:      Disconnected from server

Status:      Delaying connection for 5 seconds due to previously failed connection attempt...

Status:      Connecting to 84.XXX.XX.XX:21...

Status:      Connection established, waiting for welcome message...

Status:      Initializing TLS...

Status:      TLS connection established.

Status:      Logged in

Status:      Starting upload of /Users/xxxxxx/Documents/Websites/xxxxxx/xxxxx.gif

Status:      File transfer successful, transferred 3309 bytes in 1 second

Fer_Orange
Moderator

Gracias.

 

Posiblemente la causa sea el uso de los puertos a través de la línea móvil, que funciona diferente a como se gestiona desde un router de fibra o de ADSL. ¿Tienes opción de comunicarte con tu servicio de hosting para ver si tienen algún tipo de argumentario al respecto?

 

Entiendo que el resto de servicios que usas te funciona correctamente a través del router 4G, ¿es así?


Si tu duda ha sido resuelta, ayuda al resto de usuarios marcándola como solución
 
 
Si lees un comentario que te ha sido útil, ayuda a mejorar la comunidad dándole un "gracias"
 


ashaw
Nuevo

OK, gracias, a ver si el servicio técnico de mi hosting puede ayudar. Sí, todo lo demás funciona bien con el router 4G.

 

Por cierto, no tengo el mismo problema con otra página en otro hosting que utiliza SFTP en vez de 'FTP over TLS'

 

He encontrado lo siguiente en internet:

 

And now, compare the client log with the server log from the same session: It will be a jaw-dropping experience for the 4G connection, revealing manipulated FTP commands and server replies. Mobile providers actively and purposely sabotage FTP over TLS, in order to keep the connection in clear text, mostly for traffic-shaping. FTP over TLS is end-to-end encryption and goes directly against their goals.

Unfortunately, the only real solution is: Don't use mobile providers, or, at least, one that allows FTP over TLS. While you can test if FTP over TLS Implicit (port 990) works, there's a good chance it won't, due to a block.

 

un saludo